summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Neumann2017-11-10 20:48:46 +0100
committerJan Neumann2017-11-10 20:48:46 +0100
commitfcac45064c4547a6e6b19a0b8f008ab5b6208318 (patch)
treeeb69e764e258e19f6f3a0357b2acac267274120c /PKGBUILD
parent381338e54e61b8b4be137ab3ce1e5ad526e25084 (diff)
downloadaur-fcac45064c4547a6e6b19a0b8f008ab5b6208318.tar.gz
new dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecbbdae80f57..83df7e436a1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,25 +9,30 @@ pkgdesc='liquidshell is an alternative to plasmashell'
arch=('x86_64')
url='https://cgit.kde.org/liquidshell.git/'
license=('GPL3')
-depends=('networkmanager-qt' 'bluez-qt' 'kcmutils')
+depends=('networkmanager-qt' 'bluez-qt' 'kcmutils' 'knewstuff')
makedepends=('cmake' 'extra-cmake-modules' 'git')
source=("${pkgname}-${pkgver}::git+git://anongit.kde.org/liquidshell.git")
sha256sums=('SKIP')
pkgver() {
+
cd ${srcdir}/${pkgname}-${pkgver}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
}
build() {
+
cd ${srcdir}/${pkgname}-${pkgver}
mkdir build && cd build
cmake ..
-
- make
- }
+ make
+
+}
package() {
+
install -Dm755 ${srcdir}/${pkgname}-${pkgver}/build/liquidshell ${pkgdir}/usr/bin/liquidshell
+
}