summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2019-05-16 19:58:58 -0400
committerDavid Parrish2019-05-16 19:58:58 -0400
commit30f422e34d888dfb79a40dfc91bb30fed2df9686 (patch)
treed5e3b758af57e6f7569a55615f219d3476bb58f2 /PKGBUILD
parentafcae7a2247d766664122c7111692bd9c9d3878d (diff)
downloadaur-30f422e34d888dfb79a40dfc91bb30fed2df9686.tar.gz
Add gmp dependency. Apply namcap suggestions.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d5654c5a03b..49aab9fb4e5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,6 +5,7 @@ pkgver=r7.1aaccb5
pkgrel=1
pkgdesc="Prints all systemd timers to stdout"
arch=('i686' 'x86_64')
+depends=('gmp')
makedepends=('git' 'stack')
url="https://github.com/dmp1ce/list-all-systemd-timers"
license=('custom:Unlicense')
@@ -18,7 +19,7 @@ pkgver() {
}
build() {
- msg2 'Building...'
+ # Building
cd "${pkgname}" || exit
stack ghc list-all-systemd-timers.hs
}
@@ -26,10 +27,10 @@ build() {
package() {
cd "${pkgname}" || exit
- msg2 'Installing license...'
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/list-all-systemd-timers"
+ # Installing license
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/list-all-systemd-timers-git"
- msg2 'Installing...'
+ # Installing
mkdir -p "$pkgdir/usr/bin"
install -Dm 755 list-all-systemd-timers -t "$pkgdir/usr/bin"
}