summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTechSour122021-07-22 00:16:36 +0300
committerTechSour122021-07-22 00:16:36 +0300
commit8647c93d91e4d104ee9331c820b80114d62207b7 (patch)
tree87d518091d3fc728df9f4cb4ede6a09631d39962 /PKGBUILD
downloadaur-8647c93d91e4d104ee9331c820b80114d62207b7.tar.gz
repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f4162f8b792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: ffqq <shuttara@gmail.com>
+pkgname=liteaur
+pkgver=1.1
+pkgrel=1
+pkgdesc="LiteAUR: The shell script light-weight AUR helper"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/TechSour12/liteaur"
+license=('GPL3')
+depends=('pacman' 'git')
+optdepends=('doas' 'sudo')
+provides=(liteaur)
+source=("${pkgname}-${pkgver}.tar.gz::https://gitlab.com/TechSour12/liteaur/-/archive/v${pkgver}/liteaur-v${pkgver}.tar.gz")
+noextract=()
+md5sums=("d4c30803bc8e423b8185f2c3f717afcb")
+validpgpkeys=()
+
+package() {
+ cd "$pkgname-v$pkgver"
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}