summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonid Gnezdilov2020-05-29 15:09:01 +0300
committerLeonid Gnezdilov2020-05-29 15:09:01 +0300
commitf121b8eca45d7db69a94a45e7b28ef8185f6820f (patch)
treea4febe34079fa9a8e652f5795f4a2d769f8114d7 /PKGBUILD
downloadaur-f121b8eca45d7db69a94a45e7b28ef8185f6820f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49364dcbb358
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Leone <comdir@infonix.info>
+pkgname=litemanager
+pkgver=4.9
+pkgrel=1
+epoch=
+pkgdesc="remote access software for remote administration of computers over the Internet or remote control in a local network, for distant learning, providing remote support to users and supervising work activity of employees."
+arch=('x86_64')
+url="http://www.litemanager.com"
+license=('custom')
+groups=()
+depends=()
+makedepends=('gendesk')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://litemanager.com/soft/LiteManager_linux.zip")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+
+ echo "Creating desktop file"
+ gendesk -f -n --pkgname ${pkgname} \
+ --pkgdesc "${pkgdesc}" \
+ --categories "Graphics;" \
+ --icon "${_pkgname}" \
+ --exec "litemanager"
+
+}
+
+
+package() {
+ install -d "${pkgdir}/" "$pkgdir/opt/${_pkgname}"
+ install -Dm755 "${srcdir}/LiteManager" "$pkgdir/opt/litemanager/litemanager"
+ mkdir -p $pkgdir/usr/bin
+ ln -s "/opt/litemanager/LiteManager" "$pkgdir/usr/bin/litemanager"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ #install -Dm644 "${srcdir}/${pkgname}.svg" "${pkgdir}/usr/share/pixmaps/${pkgname}.svg"
+}