summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucki2020-02-11 00:05:24 +0100
committerLucki2020-08-02 04:22:13 +0200
commit80469780b575920e0743f8c1f3e456293024048a (patch)
tree73b71a38c15d8cf6aab437bad54221af3390db78 /PKGBUILD
parent34842a368f082f3aabf174dbf8f055a16ce610ec (diff)
downloadaur-80469780b575920e0743f8c1f3e456293024048a.tar.gz
upgpkg: clonepoint-git r72.a9bb2a1-1
upgpkg: fife 0.4.2-2 upgpkg: gfxtablet-git 50.128060d-2 upgpkg: gtksourceview-lolcode 0.1-3 upgpkg: lci-git 0.10.5.r27.g6762b72-1 upgpkg: lix-git 0.9.29.r1572290530.9b38eb65-1 upgpkg: lix 0.9.30-1 upstream release upgpkg: londonlaw-git 0.3.0_pre2.r1.g35d419f-4 upgpkg: opsu-git 0.16.1.r6.g28003bfb-1 upgpkg: opsu 0.16.1-1 upstream release upgpkg: smokinguns-git 1.1.r859.gf5d9ecf2-7 upgpkg: unknown-horizons-git 2019.1.r109.gac387940c-1 upgpkg: unknown-horizons 2019.1-4 upgpkg: yaup-git 0.1.r4.g7ee3fdb-1 upgpkg: clonepoint-git r72.a9bb2a1-1 upgpkg: fife 0.4.2-2 upgpkg: gfxtablet-git 50.128060d-2 upgpkg: gtksourceview-lolcode 0.1-3 upgpkg: lci-git 0.10.5.r27.g6762b72-1 upgpkg: lix-git 0.9.29.r1572290530.9b38eb65-1 upgpkg: lix 0.9.30-1 upstream release upgpkg: londonlaw-git 0.3.0_pre2.r1.g35d419f-4 upgpkg: opsu-git 0.16.1.r6.g28003bfb-1 upgpkg: opsu 0.16.1-1 upstream release upgpkg: smokinguns-git 1.1.r859.gf5d9ecf2-7 upgpkg: unknown-horizons-git 2019.1.r109.gac387940c-1 upgpkg: unknown-horizons 2019.1-4 upgpkg: yaup-git 0.1.r4.g7ee3fdb-1 shellcheck + formatting
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3b9c624729e..fbeb446b489a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
# Contributor: Carl Reinke <mindless2112 gmail com>
+# shellcheck disable=SC2034,2154
pkgname=lix
pkgver=0.9.30
@@ -16,7 +17,7 @@ url="http://www.lixgame.com/"
license=('custom:CC0')
depends=('allegro' 'enet' 'hicolor-icon-theme' 'liblphobos')
makedepends=('git' 'ldc' 'dub')
-_dubv=( "4.0.4+5.2.0" # allegro
+_dubv=( "4.0.4+5.2.0" # allegro
"0.7.1" # bolts
"4.1.0" # derelict-enet
"3.0.0-beta.2" # derelict-util
@@ -64,8 +65,7 @@ sha512sums+=( 'SKIP'
'SKIP'
)
-_build()
-{
+_build() {
_r=0
# add local dependencies to search path
@@ -82,7 +82,8 @@ _build()
--compiler=ldc \
`# force FHS compatibility:` \
--build=releaseXDG \
- || _r="$?"
+ `# Save result code for later when failed:` \
+ || _r="$?"
# remove local dependencies from search path so dub won't find them
# later again
@@ -92,27 +93,23 @@ _build()
# and their latest version
dub clean-caches
- if [[ "$_r" != 0 ]]
- then
+ if [[ "$_r" != 0 ]]; then
# dub failed so we also fail after we removed the local dependencies
return "$_r"
fi
}
-build()
-{
+build() {
cd "$_gitname-$pkgver" || exit
_build build
}
-check()
-{
+check() {
cd "$_gitname-$pkgver" || exit
_build test
}
-package()
-{
+package() {
# install application entry
install -Dm644 \
`# SRCFILE:` \