summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2020-01-31 16:34:17 +0100
committerAntoine Viallon2020-01-31 16:34:17 +0100
commit0bd7c7322b4f66c99c07cf6df9e5408000e8c983 (patch)
tree3c7d12c69c7b65cc6bf747da830eeb6df18835c5 /PKGBUILD
downloadaur-0bd7c7322b4f66c99c07cf6df9e5408000e8c983.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59daa32c1c7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Antoine Viallon <antoine.viallon@gmail.com>
+pkgname=llgl-git
+_pkgname=LLGL
+pkgver=r2253.d9ed15ed
+pkgrel=1
+pkgdesc="Low Level Graphics Library (LLGL) is a thin abstraction layer for the modern graphics APIs OpenGL, Direct3D, Vulkan, and Metal"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/LukasBanana/LLGL"
+license=('LICENSE.txt')
+#depends=()
+makedepends=(
+ 'cmake'
+ 'make'
+)
+source=("git+https://github.com/aviallon/LLGL.git#branch=patch-linuxlib")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
+ make DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/usr/lib/"
+ cp -Rv build/build/* "$pkgdir/usr/lib/"
+ cp -Rv include "$pkgdir/usr/"
+ #make DESTDIR="$pkgdir" install
+}