summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLW-archlinux2019-07-11 14:02:22 +0200
committerLW-archlinux2019-07-11 14:02:22 +0200
commit180a4594499faaac62e16d0c38ef6c793c5bd920 (patch)
tree588fec1ca03ffa7d84d55a0e4ac436f479d153d7 /PKGBUILD
parent0580fe10efca5f52e380bde04679e628fba56070 (diff)
downloadaur-180a4594499faaac62e16d0c38ef6c793c5bd920.tar.gz
running multiple tests in same ninja command sometimes caused hangs, separated tests so each has their own ninja command
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3d8aef9dd91..b36a5830a499 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
pkgname=('llvm-git' 'llvm-libs-git')
-pkgver=9.0.0_r318181.92f95d21912
+pkgver=9.0.0_r321346.e23be09e66d
pkgrel=1
_ocaml_ver=4.07.1
arch=('x86_64')
@@ -111,7 +111,11 @@ build() {
check() {
cd _build
- ninja $NINJAFLAGS check check-polly check-lld check-lldb check-clang
+ ninja $NINJAFLAGS check
+ ninja $NINJAFLAGS check-polly
+ ninja $NINJAFLAGS check-lld
+ ninja $NINJAFLAGS check-lldb
+ ninja $NINJAFLAGS check-clang
}
package_llvm-git() {