summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarl L. Brennan2024-10-07 21:01:06 +0200
committerKarl L. Brennan2024-10-07 21:01:06 +0200
commite2192cc6619323d9b4ea4dcf65fbebc8ea3a8af9 (patch)
treea61cef754c3f99d3b568933e956d0e5a7cf6e7fa /PKGBUILD
parentef6ae5b6d3f757dc82f3cdbf6b77aafe2d6b8fe3 (diff)
downloadaur-e2192cc6619323d9b4ea4dcf65fbebc8ea3a8af9.tar.gz
20241001, add aarch64 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05f627d49c69..1c4582ee1c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Maintainer: Karl Ludwig Brennan <karlludwigbrennan@outlook.com>
pkgname=llvm-mingw-w64-toolchain-ucrt-bin
-pkgver=20240619
-pkgrel=2
+pkgver=20241001
+pkgrel=1
pkgdesc="LLVM/Clang/LLD based mingw-w64 toolchain (UCRT) targeting i686, x86-64, armv7, and aarch64"
_crt=ucrt
-arch=('x86_64')
+arch=('aarch64' 'x86_64')
url="https://github.com/mstorsjo/llvm-mingw"
license=('custom')
depends=()
provides=('llvm-mingw-w64-toolchain' 'mingw-w64-binutils' 'mingw-w64-crt' 'mingw-w64-gcc' 'mingw-w64-headers' 'mingw-w64-winpthreads')
-source=("https://github.com/mstorsjo/llvm-mingw/releases/download/${pkgver}/llvm-mingw-${pkgver}-${_crt}-ubuntu-20.04-x86_64.tar.xz")
-sha256sums=('27d33157cc252c29ad6f777a96a0d94176fea1b534ff09b5071485def143b90e')
+source=("https://github.com/mstorsjo/llvm-mingw/releases/download/${pkgver}/llvm-mingw-${pkgver}-${_crt}-ubuntu-20.04-${CARCH}.tar.xz")
+if [ "$CARCH" = "aarch64" ]; then
+ sha256sums=('01281605738a7d12fe4b45a444b10469975024be560dafad34edc6d2f1154841')
+else
+ sha256sums=('5ef76d9a772f5896fafb61a1b670bc13e5336692ecdcea2b312a64552d58a1a2')
+fi
options=(!strip)
package() {
mkdir -p ${pkgdir}/opt/llvm-mingw/llvm-mingw-$_crt
- cp -dpr --no-preserve=ownership ./llvm-mingw-${pkgver}-${_crt}-ubuntu-20.04-x86_64/* "${pkgdir}/opt/llvm-mingw/llvm-mingw-$_crt"
+ cp -dpr --no-preserve=ownership ./llvm-mingw-${pkgver}-${_crt}-ubuntu-20.04-${CARCH}/* "${pkgdir}/opt/llvm-mingw/llvm-mingw-$_crt"
}