summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2023-03-04 14:47:55 +0100
committerLone_Wolf2023-03-04 14:47:55 +0100
commitcefafd3308f9321e83576ab5455dd717a63cbc82 (patch)
tree53b3ba3c6ff286da569c8d0eb1d4c1c21342b01c /PKGBUILD
parent84afb56696e392af9517f30cb406fee5073a3498 (diff)
downloadaur-cefafd3308f9321e83576ab5455dd717a63cbc82.tar.gz
revert 2 more commits
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e81a8bdbf97..c2a1d05db245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgbase=llvm-minimal-git
pkgname=('llvm-minimal-git' 'llvm-libs-minimal-git' 'spirv-llvm-translator-minimal-git')
-pkgver=17.0.0_r452967.d9f6077db05c
+pkgver=17.0.0_r453589.44c6b905f852
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -28,18 +28,24 @@ source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
"git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git"
'0001-IPSCCP-Remove-legacy-pass.patch'
'0001-OCaml-Remove-all-PassManager-related-functions.patch'
+ '0001-llvm-c-Remove-bindings-for-creating-legacy-passes.patch'
+ '0001-IPO-Remove-various-legacy-passes.patch'
)
md5sums=('SKIP'
'295c343dcd457dc534662f011d7cff1a'
'SKIP'
'245054bc67dec3eb30329bbdeed171b1'
- '4c5ac9bca18c8a92280b1699f2f85a16')
+ '4c5ac9bca18c8a92280b1699f2f85a16'
+ '286194131e1b5df0fe50ecd0f1b58eb2'
+ '179d535366bdb73c6b02850210aca69c')
sha512sums=('SKIP'
'75e743dea28b280943b3cc7f8bbb871b57d110a7f2b9da2e6845c1c36bf170dd883fca54e463f5f49e0c3effe07fbd0db0f8cf5a12a2469d3f792af21a73fcdd'
'SKIP'
'4c1e8a455163ceb1e7d3f09f5e68f731e47f2346a2f62e1fe97b19f54c16781efc0b75d52304fe9d4aa62512fd6f32b7bd6e12b319cbe72e7831f1a056ffbfd0'
- '92f971db948e8acd4a55cb46ef28dc394c5df07f57844b63d82fc19436e2dfe7b184599ca17d84ef4fa63f6281628d8cc734d74dcc95bc0eee8a5e7c3778f49a')
+ '92f971db948e8acd4a55cb46ef28dc394c5df07f57844b63d82fc19436e2dfe7b184599ca17d84ef4fa63f6281628d8cc734d74dcc95bc0eee8a5e7c3778f49a'
+ 'd3f5df839b49e4a853e88efaf2fb31c36efb15a91b4803f7e52414ab0e3121f4bfafc7d39edaad52a29106ca648428577f97f4fd12e7575cd3bbe009a1111901'
+ 'ab46bd37d540e9c62d99cc9e137079e077f032d0ba6531b0685d2bb91a4d832787dd12e3680c76b58d26ada7e81b3a7d8d138c303a6ffb21b593dc549aecb140')
options=('staticlibs' '!lto')
# explicitly disable lto to reduce number of build hangs / test failures
@@ -67,8 +73,10 @@ pkgver() {
}
prepare() {
-
- # revert https://github.com/llvm/llvm-project/commit/e0efe46b33068f2e651e850cdc3ede0306f1853c so the passmanager patch keeps working
+
+ #more reverts to keep legacy passmanager working
+ patch --directory="llvm-project" --reverse --strip=1 --input="${srcdir}/0001-llvm-c-Remove-bindings-for-creating-legacy-passes.patch"
+ patch --directory="llvm-project" --reverse --strip=1 --input="${srcdir}/0001-IPO-Remove-various-legacy-passes.patch"
patch --directory="llvm-project" --reverse --strip=1 --input="${srcdir}/0001-OCaml-Remove-all-PassManager-related-functions.patch"
# reverting commit b677d0753c0a771c6203607f5dbb56189193a14c , see https://gitlab.freedesktop.org/mesa/mesa/-/issues/8297
patch --directory="llvm-project" --reverse --strip=1 --input="${srcdir}/0001-IPSCCP-Remove-legacy-pass.patch"