summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2024-04-02 12:30:35 +0200
committerLone_Wolf2024-04-02 12:30:35 +0200
commitf66e48d4c0ecca2628a2c68f11787cd8b601178e (patch)
tree0cc52a90247d946517ec6cf071ba4f6e31cd4f40 /PKGBUILD
parent4911e7f5ad6925aeb1d7cb63f10f7ef1a850c5e6 (diff)
downloadaur-f66e48d4c0ecca2628a2c68f11787cd8b601178e.tar.gz
use find-delete to get rid of static libraries instead of rm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebe8284ea7f7..17cadde1529a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
pkgbase=llvm-minimal-git
pkgname=(llvm-minimal-git llvm-libs-minimal-git clang-minimal-git clang-libs-minimal-git clang-opencl-headers-minimal-git)
-pkgver=19.0.0_r494338.b361b5369ed4
+pkgver=19.0.0_r494466.1d06f41b72e4
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -173,9 +173,9 @@ package_llvm-minimal-git() {
rm "$pkgdir"/usr/lib/{LLVMgold,lib{LLVM,LTO}}.so
rm "$pkgdir"/usr/lib/libRemarks.so
- # for an unknown reason static *.a libraries are not removed from clang-minimal-git .
- # forcefully remove them
- rm "$pkgdir"/usr/lib/clang/19/lib/{i386-pc-linux-gnu,x86_64-pc-linux-gnu}/*.a
+ # for an unknown reason !staticlibs doesn't remove all static *.a libraries,
+ # ensure they are removed
+ find "$pkgdir"/usr/lib/ -depth -type f -name "*.a" -delete
# prepare folders in srcdir to store files that are placed in other package_*() functions
mkdir -p "$srcdir"{/llvm-libs/usr/lib,/clang-libs/usr/lib,/clang-opencl-headers/usr/{lib/clang/$_major_ver/include,include/clang/Basic}}