summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2015-10-21 15:43:17 +0300
committerLuchesar V. ILIEV2015-10-21 15:45:54 +0300
commit1ad73e4035d69f7549270029919550613c7e3b61 (patch)
tree393625a1c758c14543dac4ee702b2c666b05f1f2 /PKGBUILD
parent3a902a094a56e36fea9e1f0d3ca3cdc1e893922d (diff)
downloadaur-1ad73e4035d69f7549270029919550613c7e3b61.tar.gz
[CMake] Fix add_llvm_external_project()
r250835 unintentionally discarded the optional parameter to the add_llvm_external_project() macro that may point to a path when the said path is different from ${name}. This should fix it by passing ${ARGN} on to add_llvm_subdirectory(). The problem manifests itself with e.g. add_llvm_external_project(clang-tools-extra extra) from clang/tools/CMakeLists.txt References: http://reviews.llvm.org/D13783 http://llvm.org/viewvc/llvm-project?view=revision&revision=250835
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cdd6063e6db..30b5b0f9c9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,6 +47,7 @@ source=(
'clang-tools-extra::svn+http://llvm.org/svn/llvm-project/clang-tools-extra/trunk'
'compiler-rt::svn+http://llvm.org/svn/llvm-project/compiler-rt/trunk'
llvm-Config-llvm-config.h
+ llvm_cmake_modules_AddLLVM.cmake.patch
)
sha256sums=(
@@ -55,6 +56,7 @@ sha256sums=(
'SKIP'
'SKIP'
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
+ '7f87f376b43581369836b473c8508025ff9945f1f61653e9c292b165266168f8'
)
#
@@ -126,6 +128,9 @@ prepare() {
-e 's|^\([[:blank:]]*DESTINATION[[:blank:]]\+\)docs/ocaml/html|\1share/doc/ocaml|' \
-i docs/CMakeLists.txt
+ # http://reviews.llvm.org/D13936
+ patch -p2 -i "${srcdir}/llvm_cmake_modules_AddLLVM.cmake.patch"
+
mkdir -p "${srcdir}/build"
}