summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2015-09-09 15:40:45 +0300
committerLuchesar V. ILIEV2015-09-09 15:46:49 +0300
commita9933cdc02bf63fbb2d3f612f337c302af64a565 (patch)
treee44fc50fe1bc237af1f1c113ee731cee0216baa7 /PKGBUILD
parentdb2a8f571d63c53c7887a8e2852ab63867003ca5 (diff)
downloadaur-a9933cdc02bf63fbb2d3f612f337c302af64a565.tar.gz
Put all packages in a package group
This should allow for easy installation of the complete LLVM toolchain. The only package that is not part of this group are the OCaml bindings.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c132e2bb95bd..98451d2a2c82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -183,6 +183,7 @@ package_llvm-svn() {
depends=(
"llvm-libs-svn=${pkgver}-${pkgrel}"
)
+ groups=('llvm-toolchain-svn')
provides=('llvm')
replaces=('llvm')
conflicts=('llvm')
@@ -230,6 +231,7 @@ package_llvm-libs-svn() {
'libffi'
'zlib'
)
+ groups=('llvm-toolchain-svn')
provides=('llvm-libs')
replaces=('llvm-libs')
conflicts=('llvm-libs')
@@ -292,6 +294,7 @@ package_clang-svn() {
'clang-tools-extra-svn: standalone tools: syntax checking, formatting, refactoring, etc.'
'python2: git-clang-format and clang-format-diff.py support'
)
+ groups=('llvm-toolchain-svn')
provides=('clang')
replaces=('clang')
conflicts=('clang')
@@ -324,6 +327,7 @@ package_clang-analyzer-svn() {
"clang-svn=${pkgver}-${pkgrel}"
'python2'
)
+ groups=('llvm-toolchain-svn')
provides=('clang-analyzer')
replaces=('clang-analyzer')
conflicts=('clang-analyzer')
@@ -358,6 +362,7 @@ package_clang-compiler-rt-svn() {
depends=(
"clang-svn=${pkgver}-${pkgrel}"
)
+ groups=('llvm-toolchain-svn')
provides=('clang-compiler-rt')
replaces=('clang-compiler-rt')
conflicts=('clang-compiler-rt')
@@ -375,6 +380,7 @@ package_clang-tools-extra-svn() {
depends=(
"clang-svn=${pkgver}-${pkgrel}"
)
+ groups=('llvm-toolchain-svn')
provides=('clang-tools-extra')
replaces=('clang-tools-extra')
conflicts=('clang-tools-extra')