summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Arthaud2017-10-06 10:25:43 -0700
committerMaxime Arthaud2017-10-06 10:25:43 -0700
commite159750be32c07b51fb6afd9f24fd921942b561d (patch)
tree50f67631cddd2003706de837f8b228ec53c96698 /PKGBUILD
parent54313fea41565e95edc5a9558cff921c9c3ffe10 (diff)
downloadaur-e159750be32c07b51fb6afd9f24fd921942b561d.tar.gz
Enable SSP and PIE by default
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb9b55eddc70..650c9f1689f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,11 +18,17 @@ license=('custom:University of Illinois/NCSA Open Source License')
makedepends=('cmake' 'libffi' 'python2' 'libedit')
options=('staticlibs')
source=(https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
- https://releases.llvm.org/$pkgver/cfe-$pkgver.src.tar.xz{,.sig})
+ https://releases.llvm.org/$pkgver/cfe-$pkgver.src.tar.xz{,.sig}
+ 0001-GCC-compatibility-Ignore-the-fno-plt-flag.patch
+ 0002-Enable-SSP-and-PIE-by-default.patch
+ disable-llvm-symbolizer-test.patch)
sha256sums=('da783db1f82d516791179fe103c71706046561f7972b18f0049242dee6712b51'
'SKIP'
'61738a735852c23c3bdbe52d035488cdb2083013f384d67c1ba36fabebd8769b'
- 'SKIP')
+ 'SKIP'
+ 'ed4a1c3c73b31421caa0ba50d14cabc16de676a88f045d06b207bbb3006963ac'
+ '79f1a409700a83d983d7237a907aeddf342c28aa810b87b28ee27b8c5560644a'
+ '6fff47ab5ede79d45fe64bb4903b7dfc27212a38e6cd5d01e60ebd24b7557359')
validpgpkeys=('11E521D646982372EB577A1F8F0871F202119294')
prepare() {
@@ -30,6 +36,14 @@ prepare() {
mkdir build
mv "$srcdir/cfe-$pkgver.src" tools/clang
+
+ # Disable test that fails when compiled as PIE
+ # https://bugs.llvm.org/show_bug.cgi?id=31870
+ patch -Np1 < ../disable-llvm-symbolizer-test.patch
+
+ # Enable SSP and PIE by default
+ patch -Np1 -d tools/clang < ../0001-GCC-compatibility-Ignore-the-fno-plt-flag.patch
+ patch -Np1 -d tools/clang < ../0002-Enable-SSP-and-PIE-by-default.patch
}
build() {