summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Aranguren2018-09-04 17:50:21 +1000
committerLuis Aranguren2018-09-04 17:50:21 +1000
commitd015405d60ffbfab96e4fb183795c0bf909eb431 (patch)
tree217b06763517e72342a15f84f3e9bc42277d4400 /PKGBUILD
parentb4687b03d5e7dd17259d6dc35e028406c7785dda (diff)
downloadaur-d015405d60ffbfab96e4fb183795c0bf909eb431.tar.gz
update pkgver to 0.5.beta.rc1.22.g4f43c1c9 and fixed deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e3d6cbd0691..65a3e9cb11b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Jonathan Knapp <jaknapp8+aur@gmail.com>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: Jonathan Knapp <jaknapp8+aur@gmail.com>
# Contributor: Roasbeef
# URL: https://github.com/lightningnetwork/lnd
# Upstream: https://github.com/lightningnetwork/lnd
pkgname=('lnd-git')
-pkgver=0.2.1.alpha.291.ge4563ca
+pkgver=0.5.beta.rc1.22.g4f43c1c9
pkgrel=1
pkgdesc='The Lighting Network Daemon, for secure off-chain bitcoin transactions.'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/lightningnetwork/lnd'
license=('MIT')
depends=('glibc')
-makedepends=('git' 'glide' 'go')
-provides=('lnd' 'btcd')
-conflicts=('btcd')
+makedepends=('git' 'dep' 'go' 'fakeroot')
+provides=('lnd')
+conflicts=()
source=("$pkgname::git+https://github.com/lightningnetwork/lnd.git")
md5sums=('SKIP')
@@ -31,14 +32,10 @@ prepare() {
package() {
export GOPATH="$srcdir"
cd "$GOPATH/src/github.com/lightningnetwork/lnd"
- glide install
- go install . ./cmd/...
- go get -u github.com/roasbeef/btcutil
- cd $GOPATH/src/github.com/roasbeef/btcd
- glide install
+ dep ensure
go install . ./cmd/...
- for _bin in btcctl btcd lnd; do
+ for _bin in lnd lncli; do
install -Dm 755 "$srcdir/bin/$_bin" -t "$pkgdir/usr/bin";
done