summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Aranguren2019-03-15 02:35:06 +1100
committerLuis Aranguren2019-03-15 02:35:06 +1100
commite795708e49d7048661cc696a2280327b17434081 (patch)
tree8c5f77c77e9e8f50b7501dd94bbb0755b0588ffd /PKGBUILD
parentb12c95a405f25b843c22687570f00eca37053933 (diff)
downloadaur-e795708e49d7048661cc696a2280327b17434081.tar.gz
update pkgver to 0.5.2.beta.r6512.c1228ae1, changed go to go-pie as per https://wiki.archlinux.org/index.php/Go_package_guidelines#Building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a67b9aa30cb..5a7c0337fc40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,15 @@
# Upstream: https://github.com/lightningnetwork/lnd
pkgname=('lnd-git')
-pkgver=0.5.1.beta.756.g2bf22617
+pkgver=0.5.2.beta.r6512.c1228ae1
+_pkgver=0.5.2.beta.
pkgrel=1
pkgdesc='The Lightning Network Daemon, for secure off-chain bitcoin transactions.'
arch=('x86_64')
url='https://github.com/lightningnetwork/lnd'
license=('MIT')
depends=('glibc')
-makedepends=('git' 'go' 'fakeroot')
+makedepends=('git' 'go-pie' 'fakeroot')
provides=('lnd' 'lnd-cli')
conflicts=()
source=("$pkgname::git+https://github.com/lightningnetwork/lnd.git")
@@ -20,7 +21,9 @@ md5sums=('SKIP')
pkgver() {
cd $pkgname
- git describe | sed 's/^v//;s/-/./g'
+# Disabled until upstream goes back to regular versioning
+# git describe --tags | sed 's/^v//;s/-/./g'
+ printf "${_pkgver}r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {