summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorshakib2020-07-03 21:59:02 +0600
committershakib2020-07-03 21:59:02 +0600
commit19b75fcf1c06a5d77ebfda5e465bb167798a927a (patch)
tree4cebc85f73ad1a968d5a3af93fc91d87485c58d3 /PKGBUILD
parent0892a38df4df3ee6995fb83b0772f970b587f626 (diff)
downloadaur-19b75fcf1c06a5d77ebfda5e465bb167798a927a.tar.gz
updated by zc0rp10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a925fd22f630..b563b41e5a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,39 @@
# Maintainer: Shakib <hello@shakib.tech>
pkgname=local-by-flywheel-bin
-pkgver=5.6.2
+_pkgname=local-by-flywheel
+pkgver=5.6.3
pkgrel=1
pkgdesc="A program to create a local WordPress development environment."
arch=('x86_64')
url="https://localbyflywheel.com/"
-license=('freemium')
+license=('custom:proprietary')
makedepends=('rpmextract')
depends=(
'numactl'
'ncurses5-compat-libs'
'libaio'
'nettle6'
+ 'gtk3'
+ 'nss'
+ 'libjpeg-turbo'
+ 'libxss'
+ 'libxslt'
)
options=('emptydirs')
-source=("https://cdn.localwp.com/releases-stable/5.6.2+4213/local-5.6.2-linux.rpm")
-sha1sums=('cbb9e2488f727986e24b98e501a0ae40d96b8525')
+source=("https://cdn.localwp.com/releases-stable/5.6.3+4270/local-5.6.3-linux.rpm")
+sha1sums=('449960d9efad86d5af4fb66d8c50baacececde79')
package() {
-rpmextract.sh ../local-5-6-2-linux.rpm
+rpmextract.sh ../local-5.6.3-linux.rpm
mv $srcdir/usr $pkgdir/ # /usr & /opt are top-level dirs in the package
mv $srcdir/opt $pkgdir/
+
+#Create symlink the executable to /usr/bin
+mkdir "$pkgdir"/usr/bin
+ln -s "$pkgdir"/opt/Local/local "$pkgdir"/usr/bin/$_pkgname
+
+#Setuid on chrome-sandbox
+chmod u+s "$pkgdir"/opt/Local/chrome-sandbox
+
cd $pkgdir/
}