summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-16 07:47:33 +0300
committerDimitris Kiziridis2020-07-16 07:47:33 +0300
commit17cda9fe8faa059c031b626671a1e583fbb0644b (patch)
tree35c1c2c752ca9188538a0843b70dbdbc4106da69 /PKGBUILD
downloadaur-17cda9fe8faa059c031b626671a1e583fbb0644b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22d1932d2b75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=localxpose-gui
+pkgver=latest
+pkgrel=1
+pkgdesc="A reverse proxy that enables you to expose your localhost to the internet"
+arch=('x86_64')
+url='https://localxpose.io'
+license=("custom:${pkgname}")
+provides=('localxpose')
+depends=('zlib')
+makedepends=('gendesk')
+options=('!strip')
+noextract=("${pkgname}-${pkgver}.AppImage")
+source=("${pkgname}-${pkgver}.AppImage::https://lxpdownloads.sgp1.digitaloceanspaces.com/gui/LocalXpose-linux-amd64.AppImage"
+ 'LICENSE')
+sha256sums=('SKIP'
+ 'SKIP')
+
+package() {
+ chmod 755 ./${pkgname}-${pkgver}.AppImage
+ ./${pkgname}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/256x256/apps/localxpose.png "${pkgdir}/usr/share/pixmaps/localxpose-gui.png"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "LocalXpose" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Network;Application;' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}.AppImage" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+ ln -s /opt/localxpose-gui/${pkgname}.AppImage "${pkgdir}/usr/bin/localxpose-gui"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file