summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Fleischer2011-11-03 10:01:03 +0000
committerLukas Fleischer2011-11-03 10:01:03 +0000
commit4b8ca8929fa543d753bcfb4e66a11975ed103fb8 (patch)
tree9d2e04f676ecf1f7f5fe4b041097f626d442cd5e /PKGBUILD
parentf523439e1b6619ef1dab9cb1d7c6dd2335e3fb37 (diff)
downloadaur-4b8ca8929fa543d753bcfb4e66a11975ed103fb8.tar.gz
PKGBUILD cleanup. Rebuild to add signature.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f74d243b587..2be9262b1875 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Andreas Wagner <a.wagner@stud.uni-frankfurt.de>
pkgname=lockdev
pkgver=1.0.3_1.2
-pkgrel=2
-pkgdesc="Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods"
-url="http://packages.qa.debian.org/l/lockdev.html"
+_pkgver=1.0.3
+pkgrel=3
+pkgdesc='Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods.'
+url='http://packages.qa.debian.org/l/lockdev.html'
license=("GPL")
arch=('i686' 'x86_64')
-source=("http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_1.0.3.orig.tar.gz"
- "http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz")
+source=("http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${_pkgver}.orig.tar.gz"
+ "http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz")
md5sums=('64b9c1b87b125fc348e892e24625524a'
'afe2995ad3fc6551e107364d66a8e938')
build() {
- cd ${pkgname}-1.0.3
-
- patch -p1 < ../${pkgname}_${pkgver/_/-}.diff
+ cd "${pkgname}-${_pkgver}"
+ patch -p1 -i "../${pkgname}_${pkgver/_/-}.diff"
sed -i "s|CFLAGS = -g|CFLAGS = -g -fPIC|" Makefile
make shared
-
make static
}
package() {
- cd ${pkgname}-1.0.3
-
- make basedir=${pkgdir}/usr install
+ cd "${pkgname}-${_pkgver}"
+ make basedir="${pkgdir}/usr" install
}