summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Fleischer2012-09-30 13:48:42 +0000
committerLukas Fleischer2012-09-30 13:48:42 +0000
commit88695789d486cbe481c7d85a8f45305f9d80dba7 (patch)
treee2732e1fd0da38fa31ea7c1bd979619c97fafa38 /PKGBUILD
parent4b8ca8929fa543d753bcfb4e66a11975ed103fb8 (diff)
downloadaur-88695789d486cbe481c7d85a8f45305f9d80dba7.tar.gz
* Upstream update.
* Change location of lock files to "/run/lock/lockdev" (FS#31614).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2be9262b1875..dfcbe1e9bb76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Andreas Wagner <a.wagner@stud.uni-frankfurt.de>
pkgname=lockdev
-pkgver=1.0.3_1.2
+pkgver=1.0.3_1.5
_pkgver=1.0.3
-pkgrel=3
+pkgrel=1
pkgdesc='Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods.'
url='http://packages.qa.debian.org/l/lockdev.html'
license=("GPL")
@@ -13,7 +13,7 @@ arch=('i686' 'x86_64')
source=("http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${_pkgver}.orig.tar.gz"
"http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz")
md5sums=('64b9c1b87b125fc348e892e24625524a'
- 'afe2995ad3fc6551e107364d66a8e938')
+ 'c4e8a5a2e46b76b48339c232b358f579')
build() {
cd "${pkgname}-${_pkgver}"
@@ -21,8 +21,8 @@ build() {
patch -p1 -i "../${pkgname}_${pkgver/_/-}.diff"
sed -i "s|CFLAGS = -g|CFLAGS = -g -fPIC|" Makefile
- make shared
- make static
+ make shared CFLAGS="${CFLAGS} -D_PATH_LOCK=\\\"/run/lock/lockdev\\\""
+ make static CFLAGS="${CFLAGS} -D_PATH_LOCK=\\\"/run/lock/lockdev\\\""
}
package() {