summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Griffin2009-07-16 04:12:59 +0000
committerAaron Griffin2009-07-16 04:12:59 +0000
commita0119afe00fc4299366196b255a83bca05cee712 (patch)
tree4b69489125ea4dd7c188e0f4c10c20506d449fea /PKGBUILD
downloadaur-a0119afe00fc4299366196b255a83bca05cee712.tar.gz
Initial commit of community repo into svn
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec17184ee320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD,v 1.3 2009/04/09 09:51:56 sergej Exp $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Andreas Wagner <a.wagner@stud.uni-frankfurt.de>
+
+pkgname=lockdev
+pkgver=1.0.3_1.2
+pkgrel=1
+pkgdesc="Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods"
+url="http://packages.qa.debian.org/l/lockdev.html"
+license=("GPL")
+arch=('i686' 'x86_64')
+source=("http://ftp.debian.org/debian/pool/main/l/$pkgname/${pkgname}_1.0.3.orig.tar.gz"
+ "http://ftp.debian.org/debian/pool/main/l/$pkgname/${pkgname}_${pkgver/_/-}.diff.gz")
+md5sums=('64b9c1b87b125fc348e892e24625524a'
+ 'afe2995ad3fc6551e107364d66a8e938')
+
+build() {
+ cd $startdir/src/$pkgname-1.0.3
+ patch -p1 < ../${pkgname}_${pkgver/_/-}.diff || return 1
+ sed -i "s|CFLAGS = -g|CFLAGS = -g -fPIC|" Makefile
+ make shared || return 1
+ make static || return 1
+ make basedir=$startdir/pkg/usr install
+}