summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-03-06 14:51:45 +0000
committerHans-Nikolai Viessmann2018-03-06 14:51:45 +0000
commit92f60bb6f4466a02bd79a3544c54eefbe13f2250 (patch)
treeb96243e8583cf8192bf3ef10652024e345ca09f7 /PKGBUILD
downloadaur-log-malloc2-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..538a6e75b369
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+pkgname=log-malloc2-git
+pkgver=r18.dd2d44b
+pkgrel=1
+pkgdesc="Memory allocation tracking library"
+arch=('x86_64')
+url="http://devel.dob.sk/log-malloc2/"
+license=('GPL' 'LGPL')
+depends=('libunwind')
+makedepends=('git')
+source=('log-malloc2::git+https://github.com/samsk/log-malloc2.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # we need to fix the makefile to install the bins correctly
+ sed -i -e 's/"$(bindir)/"$(DESTDIR)$(bindir)/' Makefile.am
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "${pkgdir}/usr/bin"
+ make DESTDIR="$pkgdir/" install
+}