summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302019-09-09 21:50:40 +0200
committerM0Rf302019-09-09 21:50:40 +0200
commit0d58e4108f6b3f051a811e58455e662f978a510c (patch)
tree35cdbcb9dd1954c15e0dba7455570abce001f5d6 /PKGBUILD
parentae6628cbea935c5f61215b66d22d9c160c370456 (diff)
downloadaur-0d58e4108f6b3f051a811e58455e662f978a510c.tar.gz
lollypop-git: updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 489334965255..6049970f6d24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# Contributor: Ian Brunelli (brunelli) <ian@brunelli.me>
pkgname=lollypop-git
-pkgver=0.9.923.r101.g621df9b7
+pkgver=1.1.4.2.r1073.gb91d490c
pkgrel=1
pkgdesc='Music player for GNOME'
arch=(any)
url=https://gitlab.gnome.org/gnumdk/lollypop
license=(GPL)
depends=(
+ appstream-glib
gst-plugins-base-libs
gtk3
python-beautifulsoup4
python-cairo
- python-dbus
python-gobject
python-pillow
totem-plparser
@@ -29,7 +29,6 @@ makedepends=(
)
optdepends=(
'easytag: Modify tags'
- 'flatpak: Flatpak Portal'
'gst-libav: FFmpeg plugin for GStreamer'
'gst-plugins-bad: "Bad" plugin libraries'
'gst-plugins-base: "Base" plugin libraries'
@@ -38,7 +37,7 @@ optdepends=(
'kid3-qt: Store covers in tags'
'libsecret: Last.FM support'
'python-pylast: Last.FM support'
- 'python-wikipedia: Wikipedia support'
+ 'youtube-dl: Youtube support'
)
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -48,12 +47,12 @@ pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --tags \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
arch-meson lollypop build \
- --libexecdir='lib/lollypop'
+ --libexecdir='lib/lollypop'
ninja -C build
}