summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-08-13 17:58:45 -0700
committerxiota2023-08-13 17:58:45 -0700
commit81baa0284d2cefb8ba14d4447960f55de742d0be (patch)
tree4daa3f98e7f78e7506795d7fd13fa130b5feb5e4 /PKGBUILD
parent0d58e4108f6b3f051a811e58455e662f978a510c (diff)
downloadaur-81baa0284d2cefb8ba14d4447960f55de742d0be.tar.gz
1.4.36.r24.gb1c5fe1b3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD110
1 files changed, 69 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6049970f6d24..83d6422742db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,91 @@
-# Maintainer: robertfoster
+# Maintainer:
+# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Cédric Bellegarde
+# Contributor: robertfoster
# Contributor: Dan Beste <dan.ray.beste@gmail.com>
# Contributor: Frederic Bezies < fredbezies at gmail dot com>
# Contributor: Ian Brunelli (brunelli) <ian@brunelli.me>
+_pkgname=lollypop
pkgname=lollypop-git
-pkgver=1.1.4.2.r1073.gb91d490c
+pkgver=1.4.36.r24.gb1c5fe1b3
pkgrel=1
-pkgdesc='Music player for GNOME'
+pkgdesc="Music player for GNOME"
arch=(any)
-url=https://gitlab.gnome.org/gnumdk/lollypop
-license=(GPL)
+url="https://gitlab.gnome.org/World/lollypop"
+license=(GPL3)
depends=(
- appstream-glib
- gst-plugins-base-libs
- gtk3
- python-beautifulsoup4
- python-cairo
- python-gobject
- python-pillow
- totem-plparser
+ 'gst-plugins-base-libs'
+ 'gst-python'
+ 'gtk3'
+ 'libhandy'
+ 'libsoup'
+ 'python-beautifulsoup4'
+ 'python-cairo'
+ 'python-gobject'
+ 'python-pillow'
+ 'totem-plparser'
)
makedepends=(
- git
- gobject-introspection
- intltool
- itstool
- meson
+ 'appstream-glib'
+ 'git'
+ 'gobject-introspection'
+ 'intltool'
+ 'itstool'
+ 'meson'
)
optdepends=(
- 'easytag: Modify tags'
- 'gst-libav: FFmpeg plugin for GStreamer'
- 'gst-plugins-bad: "Bad" plugin libraries'
- 'gst-plugins-base: "Base" plugin libraries'
- 'gst-plugins-good: "Good" plugin libraries'
- 'gst-plugins-ugly: "Ugly" plugin libraries'
- 'kid3-qt: Store covers in tags'
- 'libsecret: Last.FM support'
- 'python-pylast: Last.FM support'
- 'youtube-dl: Youtube support'
-)
-conflicts=("${pkgname%-git}")
-provides=("${pkgname%-git}")
-source=("git+https://gitlab.gnome.org/World/${pkgname%-git}")
+ 'easytag: Modify tags'
+ 'gst-libav: FFmpeg plugin for GStreamer'
+ 'gst-plugins-bad: "Bad" plugin libraries'
+ 'gst-plugins-base: "Base" plugin libraries'
+ 'gst-plugins-good: "Good" plugin libraries'
+ 'gst-plugins-ugly: "Ugly" plugin libraries'
+ 'kid3-qt: Store covers in tags'
+ 'libsecret: Last.FM support'
+ 'python-pylast: Last.FM support'
+ 'youtube-dl: YouTube support'
+ 'yt-dlp: YouTube support'
+)
+
+conflicts=(
+ 'lollypop'
+)
+provides=(
+ 'lollypop'
+)
+replaces=(
+ 'lollypop-next-git'
+ 'lollypop-stable-git'
+)
+
+source=(
+ "$_pkgname"::"git+https://gitlab.gnome.org/World/lollypop.git"
+ "lollypop-po"::"git+https://gitlab.gnome.org/gnumdk/lollypop-po.git"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
- git describe --tags \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git config submodule.subprojects/po.url "${srcdir}/lollypop-po"
+ git -c protocol.file.allow=always submodule update
}
build() {
- arch-meson lollypop build \
- --libexecdir='lib/lollypop'
- ninja -C build
+ arch-meson "$_pkgname" build \
+ --libexecdir='lib/lollypop'
+ meson compile -C build
}
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}
-
-md5sums=('SKIP')