summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCharlie Ringström2023-12-12 13:28:29 +0100
committerCharlie Ringström2023-12-12 13:28:29 +0100
commitaadc2b8c6cfcb8f5d4e1a66b5cb2cf66b20a851a (patch)
tree7190e330b8c3bf66964c68d7736c976b319f368b /PKGBUILD
parent95cdd43d55d5b2d0f988551fa1d0c2414b014491 (diff)
downloadaur-aadc2b8c6cfcb8f5d4e1a66b5cb2cf66b20a851a.tar.gz
Change to tagged release model
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e00e16675dc1..a25fbad7303d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Charlie Ringström <c.ringstrom@gmail.com>
pkgname='longcat'
-pkgver=r117.62bfdec
-pkgrel=13
+pkgver=v0.0.4
+pkgrel=1
pkgdesc="Creates a loooonng cat in the terminal"
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/mattn/longcat"
@@ -9,21 +9,21 @@ license=('MIT')
depends=('glibc')
makedepends=('go' 'git')
#changelog="Initial release"
-source=("longcat::git+https://github.com/mattn/longcat.git")
+source=("longcat::git+https://github.com/mattn/longcat.git#tag=v$pkgver")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --tags
}
build() {
cd "$pkgname"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o longcat
}