summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Rys2021-04-04 17:34:47 +0200
committerMartin Rys2021-04-04 17:34:47 +0200
commit1b0abf19366feec76f7c6f8a8339edf6eb1dbc9e (patch)
tree51658d01448317bcf90ef2c50501432c019389fe /PKGBUILD
parentf02255f8d8b20797175562e2b836791c34af04f6 (diff)
downloadaur-1b0abf19366feec76f7c6f8a8339edf6eb1dbc9e.tar.gz
bump to 0.16.0 + fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 19 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1f532442c60..8cf18e268d39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: John Troxler <firstname dot lastname at gmail dot com>
pkgname=loot
-pkgver=0.14.6
-_pkglibver=0.14.10
+# Remove spotify hax on next version bump!
+pkgver=0.16.0
+_pkglibver=0.16.2
pkgrel=1
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
@@ -12,43 +13,38 @@ depends=('boost-libs' 'http-parser' 'libssh2' 'alsa-lib' 'nss' 'pango' 'atk' 'li
makedepends=('git' 'cmake' 'rust' 'cbindgen' 'yarn' 'boost')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
- "local://lib$pkgname-$_pkglibver.patch"
- "local://$pkgname-$pkgver.patch")
-sha256sums=('04eeedfd99282bcedd23f571f1174aaeac457504c5811e49f7e00c8c9db51908'
- 'be8ed5e7555bd3187aeb7f32c2eefdf7e327f070d986842224e03a9447feda22'
- '398a12144bec5405824b870e65b75077fd140ae7a95afd7ca21589e08af82146'
- '41e0ec231caf417f79bd895677b71d27d56af33bced919a34e93474bbde357f8')
+)
+sha256sums=('b501d73e9bc00e86dc6d14b8c5f5b96effaa7c7dca654e1768c6eabdd36b887d'
+ '13d815ab3aaf90c58135932d7fa5f40e44c190ab63e756f0a953ee44800ed197'
+)
-prepare() {
- # libloot
- cd "$srcdir/lib$pkgname-$_pkglibver"
- patch -p1 <"$srcdir/lib$pkgname-$_pkglibver.patch"
-
- # loot
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 <"$srcdir/$pkgname-$pkgver.patch"
-
- yarn install
-}
+#prepare() {
+# yarn install
+#}
build() {
# libloot
cd "$srcdir/lib$pkgname-$_pkglibver"
- mkdir build
+ yarn install
+ mkdir -p build
cd build
cmake .. -DCMAKE_SKIP_RPATH=TRUE
make loot
- mkdir pkg
+ mkdir -p pkg
cp lib$pkgname.so ./pkg/
cp -r ../include/ ./pkg/
tar -zcf lib$pkgname-$_pkglibver.tar.gz ./pkg/
# loot
cd "$srcdir/$pkgname-$pkgver"
- mkdir build
+ yarn install
+ # Spotify Hax because of domain change
+ sed -i s,opensource.spotify.com/cefbuilds,cef-builds.spotifycdn.com,g CMakeLists.txt
+ mkdir -p build
cd build
- cmake .. -DLIBLOOT_URL="$srcdir/lib$pkgname-$_pkglibver/build/lib$pkgname-$_pkglibver.tar.gz" -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE -DCMAKE_INSTALL_RPATH="/opt/$pkgname"
+ cmake .. -DLIBLOOT_URL="$srcdir/lib$pkgname-$_pkglibver/build/lib$pkgname-$_pkglibver.tar.gz" \
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE -DCMAKE_INSTALL_RPATH="/opt/$pkgname"
make LOOT
}
@@ -63,7 +59,6 @@ package() {
install -Dm644 -t "$pkgdir/opt/$pkgname" \
"$_builddir/icudtl.dat" \
"$_builddir/external/src/cef/Resources/cef_extensions.pak" \
- "$_builddir/natives_blob.bin" \
"$_builddir/snapshot_blob.bin" \
"$_builddir/v8_context_snapshot.bin" \
"$_builddir/cef.pak" \