diff options
author | sekret | 2016-12-25 22:54:08 +0100 |
---|---|---|
committer | sekret | 2016-12-25 22:54:08 +0100 |
commit | e829afe8888fa0655550f3eec5946dced0352cc3 (patch) | |
tree | ed0770897cb7d7196d08ecbbafa2aede607b8731 /PKGBUILD | |
parent | 5ad53eb7d8cbacf6411079ed3b3687ec0593ee0c (diff) | |
download | aur-e829afe8888fa0655550f3eec5946dced0352cc3.tar.gz |
updated PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 17 |
1 files changed, 12 insertions, 5 deletions
@@ -1,14 +1,14 @@ # Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d) _pkgname=lossywav pkgname=$_pkgname-git -pkgver=1.4.0p.r0.g0c8343e +pkgver=1.4.2p.r1.r0.gd110728 pkgrel=1 pkgdesc="An attempt to port lossyWAV to POSIX." arch=('i686' 'x86_64' 'armv6h' 'armv7h') url="https://github.com/MoSal/lossywav-for-posix" license=('GPL') -depends=('gcc-libs') -makedepends=('git') +depends=('fftw') +makedepends=('git' 'python') provides=("$_pkgname") conflicts=("$_pkgname") source=("$_pkgname::git+https://github.com/MoSal/lossywav-for-posix.git") @@ -19,14 +19,21 @@ pkgver() { git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' } +prepare() { + cd "$_pkgname" + ./waf configure \ + --prefix="$pkgdir/usr" \ + --enable-fftw3 +} + build() { cd "$_pkgname" - make + ./waf build } package() { cd "$_pkgname" - install -Dm755 lossywav "$pkgdir/usr/bin/lossywav" + ./waf install --destdir=/ } # vim:set ts=2 sw=2 et: |