summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2021-10-17 17:27:52 +0200
committerJose Riha2021-10-17 17:27:52 +0200
commit4f4a127a7a8a3d741fcbddb99d48dc1703f335b6 (patch)
tree105bccd9657571ac4dd1e6010e6c96ddc9289d0d /PKGBUILD
parentbcbf7de93015302d3c32ba7e916f9ffa43962fc3 (diff)
downloadaur-4f4a127a7a8a3d741fcbddb99d48dc1703f335b6.tar.gz
Adopt and fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ed2563ea771..7d3d8653452c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,50 @@
-# Maintainer: Kyle McLamb <alloyed@tfwno.gf>
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Kyle McLamb <alloyed@tfwno.gf>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Linus Sjögren <thelinx@unreliablepollution.net>
# Contributor: Eric Forgeot < http://anamnese.online.fr >, dreeze
+# Contributor: bageljr
pkgname=love10
pkgver=0.10.2
-pkgrel=1
+pkgrel=2
pkgdesc="An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences"
arch=(i686 x86_64)
url="http://love2d.org/"
license=('zlib')
depends=('luajit' 'physfs' 'freetype2' 'mpg123' 'openal' 'libvorbis' 'libmodplug' 'sdl2')
-source=("hg+https://bitbucket.org/rude/love#tag=0.10.2")
-makedepends=('mercurial')
+source=("https://github.com/love2d/love/releases/download/0.10.2/love-0.10.2-linux-src.tar.gz")
+conflicts=('love')
+provides=('love')
+makedepends=('git')
md5sums=('SKIP')
build() {
- cd "$srcdir"/love
+ cd "$srcdir"/love-$pkgver
# Update version information in configure script
- msg "Updating version information"
- head -c 15 platform/unix/configure.ac > configure.ac.tmp
+ echo "Updating version information"
+ head -c 15 configure.ac > configure.ac.tmp
echo " [0.10.2])" >> configure.ac.tmp
- tail -n +2 platform/unix/configure.ac >> configure.ac.tmp
+ tail -n +2 configure.ac >> configure.ac.tmp
mv configure.ac.tmp platform/unix/configure.ac
# Skip installing desktop files, icons, etc
- head -n 4 platform/unix/Makefile.am > Makefile.am.tmp
+ head -n 4 Makefile.am > Makefile.am.tmp
mv Makefile.am.tmp platform/unix/Makefile.am
# Generate a configure script for love-hg (note the suffix), then configure
- msg "Generating makefiles"
- sh platform/unix/automagic 10
+ echo "Generating makefiles"
+ #sh platform/unix/automagic 10
./configure --enable-silent-rules --prefix=/usr LDFLAGS=""
# Finally build
- msg "Building"
+ echo "Building"
make
}
package() {
- cd "$srcdir"/love
-
+ cd "$srcdir"/love-$pkgver
make DESTDIR="$pkgdir" install
-
install -Dm0644 "license.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}