summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorosch2019-02-10 15:34:18 +0100
committerosch2019-02-10 15:34:18 +0100
commitc5d9931620184022c99ac18485367b8ffee8a5c1 (patch)
tree4b4f4f7b2445eff8a210de48b297d3754f013eda /PKGBUILD
downloadaur-c5d9931620184022c99ac18485367b8ffee8a5c1.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cca326d3119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: osch <oliver@luced.de>
+pkgname=lrexrepl
+pkgver=0.2.0
+pkgrel=1
+rockrel=1
+pkgdesc="Commandline tool: Search and Replace in multiple files using Regular Expressions and Lua"
+arch=('i686' 'x86_64')
+url="https://luarocks.org/modules/osch/$pkgname"
+license=('MIT')
+depends=('lua' 'lrexlib-pcre' 'lua-filesystem')
+source=("https://github.com/osch/$pkgname/archive/v$pkgver.tar.gz")
+noextract=()
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 lrexrepl "$pkgdir/usr/bin/lrexrepl"
+}
+
+md5sums=('45432d2704627298edd8e8c88238744a')