summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-03-02 21:44:38 +0100
committersL1pKn072022-03-02 21:44:38 +0100
commit1c3a6f9a750c43daac10e6f1fc4044aad4e326c2 (patch)
treed9ad078a2e4008d956b54e574c36adfbde804f98 /PKGBUILD
parent252daf059b8aed428699c1470f5c9a1a4551bf3a (diff)
downloadaur-1c3a6f9a750c43daac10e6f1fc4044aad4e326c2.tar.gz
update _create_links() function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1122f49d2d85..238cbf9d5a83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,9 +39,9 @@ options=('!strip')
_create_links() {
# create soname links
- for _lib in $(find "${pkgdir}" -type f -name '*.so*'); do
+ find "${pkgdir}" -type f -name '*.so*' -print0 | while read -d $'\0' _lib; do
_soname=$(dirname "${_lib}")/$(readelf -d "${_lib}" | grep -Po 'SONAME.*: \[\K[^]]*' || true)
- _base=$(echo ${_soname} | sed -r 's/(.*).so.*/\1.so/')
+ _base=$(echo ${_soname} | sed -r 's/(.*)\.so.*/\1.so/')
[[ -e "${_soname}" ]] || ln -s $(basename "${_lib}") "${_soname}"
[[ -e "${_base}" ]] || ln -s $(basename "${_soname}") "${_base}"
done