summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072021-01-16 21:22:15 +0100
committersL1pKn072021-01-16 21:22:15 +0100
commite962ad5831f325946db6c3450338b1ad4ed643c8 (patch)
tree0b9750e02dddc25b157822127341bda702998a35 /PKGBUILD
parentaef73ffe365dad6dce85164d22151d273a88fc1b (diff)
downloadaur-e962ad5831f325946db6c3450338b1ad4ed643c8.tar.gz
rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05809871c774..3ae437e4bd4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,15 @@
pkgname=lsi-openpegasus
pkgver=2.14.1
-pkgrel=2
+pkgrel=3
pkgdesc="Openpegasus libs for LSI (Broadcom) Raid products"
arch=('x86_64')
url='http://www.avagotech.com/products/server-storage'
license=('custom:TOG')
-depends=('sqlite')
+depends=('sqlite'
+ 'openssl'
+ 'libxcrypt'
+ )
makedepends=('icu'
'openssl'
'net-snmp'
@@ -58,15 +61,21 @@ prepare() {
# set lib output directory
setconf configure libbase lib
- export PEGASUS_EXTRA_C_FLAGS="${CFLAGS}"
- export PEGASUS_EXTRA_CXX_FLAGS="${CXXFLAGS}"
- export PEGASUS_EXTRA_PROGRAM_LINK_FLAGS="${LDFLAGS}"
+ # add missing z library
+ sed 's|lcrypt|& -lz|g' -i mak/config-linux.mak
- ./configure
}
build() {
cd pegasus
+
+ export PEGASUS_EXTRA_C_FLAGS="${CFLAGS} -Wall -Wno-unused -fno-strict-aliasing"
+ export PEGASUS_EXTRA_CXX_FLAGS="${PEGASUS_EXTRA_C_FLAGS} -std=c++14"
+ export PEGASUS_EXTRA_LINK_FLAGS="${LDFLAGS}"
+ export PEGASUS_EXTRA_PROGRAM_LINK_FLAGS="-pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack"
+
+ ./configure
+
make -f GNUmakefile
}