summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedro Vitor Piassa2020-11-28 20:49:15 -0300
committerPedro Vitor Piassa2020-11-28 20:49:15 -0300
commitd1c2be57eff44a52dbef297e1b55e20962b1e2a3 (patch)
tree749e06a48a05ce4d7e3e3c14495c0d2f41113902 /PKGBUILD
downloadaur-d1c2be57eff44a52dbef297e1b55e20962b1e2a3.tar.gz
lspac first release, version 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62ebd90ba717
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pedro P. <pvṕscŕipt [at] gmàil -rmthis- [døt] c0m>
+pkgname=lspac
+pkgver=1.0.0
+pkgrel=1
+epoch=0
+pkgdesc="Display package informations in a parse friendly fashion"
+arch=('x86_64')
+url="https://github.com/pvpscript/lspac"
+license=('GPL3')
+groups=()
+depends=('pacman')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/pvpscript/lspac/raw/main/versions/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('c7de3de6a05a1c191c3d3e04c50decb6')
+sha256sums=('8b68a57a54c4b255890d42eb67d175f3ad3f38c940e9beae13cbeb0f9a8b5401')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}