summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera Micó2023-11-22 23:19:22 +0000
committerJoan Bruguera Micó2023-11-22 23:19:22 +0000
commit409462a3e0121782eb806ddfba5656f1a89b2397 (patch)
tree8b2bc9dfd0f51769538b58df2321442d04cc616a /PKGBUILD
parent30f66127e5be8d1cb6d428b322ff7f01a1fc556b (diff)
downloadaur-409462a3e0121782eb806ddfba5656f1a89b2397.tar.gz
Fix building with a custom SRCDEST
When building with makepkg with a SRCDEST environment variable with nested directories (e.g. 'a/b/c') gendesk is unable to find the PKGBUILD and generates a wrong .desktop file. Explicitly pass --pkgname and --pkgdesc (which seems to be what most official Arch packages do) to fix this issue. Also get rid of the setconf makedepends by using --categories.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4d3ef5b806e..df125d3387df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ltsa
pkgver=3.0
-pkgrel=7
+pkgrel=8
pkgdesc="Labelled Transition System Analyser, a verification tool for concurrent systems"
arch=('any')
url="http://www.doc.ic.ac.uk/ltsa/"
@@ -20,7 +20,7 @@ url="http://www.doc.ic.ac.uk/ltsa/"
license=('unknown')
depends=('java-runtime' 'bash' 'libcups')
install=ltsa.install
-makedepends=('imagemagick' 'setconf' 'gendesk')
+makedepends=('imagemagick' 'gendesk')
source=("http://www.doc.ic.ac.uk/~jnm/book/$pkgname/${pkgname}tool.zip"
"$pkgname.sh")
sha256sums=('9ed894c4f2ae22e119a4f48e6e3f36b38b08f8fe85a6ac85564f4c5045fe9046'
@@ -28,8 +28,7 @@ sha256sums=('9ed894c4f2ae22e119a4f48e6e3f36b38b08f8fe85a6ac85564f4c5045fe9046'
build() {
cd "$srcdir"
- gendesk -n
- setconf "$pkgname.desktop" Categories "Education;Java;"
+ gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --categories "Education;Java"
echo "Generating $pkgname.png..."
convert "${pkgname}tool/$pkgname.ico" "$pkgname.png"
}