summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvy Foster2017-10-26 20:57:35 -0500
committerIvy Foster2017-10-26 20:57:35 -0500
commit86570a006381f3c00815e3a39ec808cf45922fd3 (patch)
tree1c9b9e50df6e52ab1a8207d67431db24b1e4ce04 /PKGBUILD
downloadaur-86570a006381f3c00815e3a39ec808cf45922fd3.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde3f65011a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Ivy Foster <code@escondida.tk>
+
+pkgname=lua-cosmo-git
+pkgver=16.06.04
+pkgrel=1
+pkgdesc='Safe templates for Lua'
+arch=(i686 x86_64)
+url='http://cosmo.luaforge.net/'
+license=(MIT)
+
+depends=(lua lua-lpeg)
+makedepends=(luarocks)
+
+provides=(lua-cosmo)
+conflicts=(lua-cosmo)
+
+source=('git+https://github.com/mascarenhas/cosmo.git')
+md5sums=(SKIP)
+
+package() {
+ luarocks --tree="$pkgdir/usr" install --deps-mode=none cosmo
+ find "$pkgdir/usr" -name manifest -delete
+}