summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Smith2019-01-25 21:39:55 -0500
committerStephen Smith2019-01-25 21:39:55 -0500
commit37705f30e92897f521990352616a6ea6b3dbcd20 (patch)
tree03d954b559ed164fd515e8f6f928e045478f50f0 /PKGBUILD
downloadaur-37705f30e92897f521990352616a6ea6b3dbcd20.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd4b0023537a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+
+pkgname=lua-coxpcall
+_rockname=coxpcall
+pkgver=1.16.0
+_tag=${pkgver//./_}
+pkgrel=1
+pkgdesc="Coxpcall encapsulates the protected calls with a coroutine based loop, so errors can be dealed without the usual pcall/xpcall issues with coroutines."
+arch=('i686' 'x86_64')
+url="http://keplerproject.github.io/coxpcall/"
+license=('MIT')
+depends=('lua')
+makedepends=('luarocks')
+conflicts=()
+source=("${_rockname}-${_tag}.tar.gz::https://github.com/keplerproject/${_rockname}/archive/v${_tag}.tar.gz")
+md5sums=('1d25a2e5b0c0cd529b1fdc35dea2a06b')
+
+build() {
+ cd "$_rockname-$_tag"
+ luarocks make --pack-binary-rock --deps-mode=none "rockspec/$_rockname-$pkgver-1.rockspec"
+}
+
+package() {
+ luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$_rockname-$_tag"/*.rock
+ find "$pkgdir/usr" -name manifest -delete
+}