summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordaurnimator2017-10-19 14:10:40 +1100
committerdaurnimator2017-10-19 14:10:40 +1100
commit776817370811d820e4005ca0216589128e93c072 (patch)
tree9d7415f53844717ca0cce3ce38009ed579c4dcdc /PKGBUILD
parentbae8db37153940a129350b6cff25dfada722c242 (diff)
downloadaur-776817370811d820e4005ca0216589128e93c072.tar.gz
Update to 20171014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c1c7043a654..aea59e10c29d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Daurnimator <quae@daurnimator.com>
pkgname=(lua-cqueues lua51-cqueues lua52-cqueues)
-pkgver=20161215
+pkgver=20171014
pkgrel=0
arch=('i686' 'x86_64')
url='http://25thandclement.com/~william/projects/cqueues.html'
license=('MIT')
makedepends=('lua' 'lua51' 'lua52')
depends=('openssl')
-source=('https://github.com/wahern/cqueues/archive/rel-20161215.tar.gz')
-md5sums=('3e5bfb9ccb7fa8eea4f5d367dd0fe10a')
+source=('https://github.com/wahern/cqueues/archive/rel-20171014.tar.gz')
+md5sums=('d3912ad77724b223e24d1ba55e9a9293')
build() {
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make prefix=/usr
}
package_lua-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.3'
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make DESTDIR=${pkgdir} prefix=/usr install5.3
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -26,7 +26,7 @@ package_lua-cqueues() {
package_lua51-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.1'
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make DESTDIR=${pkgdir} prefix=/usr install5.1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -34,7 +34,7 @@ package_lua51-cqueues() {
package_lua52-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.2'
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make DESTDIR=${pkgdir} prefix=/usr install5.2
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}