summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordaurnimator2017-01-29 01:32:08 +1100
committerdaurnimator2017-01-29 01:32:08 +1100
commitbae8db37153940a129350b6cff25dfada722c242 (patch)
tree8b0f72be7826f4b3cc92985fe27f933c1224abf4 /PKGBUILD
downloadaur-bae8db37153940a129350b6cff25dfada722c242.tar.gz
Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c1c7043a654
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daurnimator <quae@daurnimator.com>
+
+pkgname=(lua-cqueues lua51-cqueues lua52-cqueues)
+pkgver=20161215
+pkgrel=0
+arch=('i686' 'x86_64')
+url='http://25thandclement.com/~william/projects/cqueues.html'
+license=('MIT')
+makedepends=('lua' 'lua51' 'lua52')
+depends=('openssl')
+source=('https://github.com/wahern/cqueues/archive/rel-20161215.tar.gz')
+md5sums=('3e5bfb9ccb7fa8eea4f5d367dd0fe10a')
+build() {
+ cd cqueues-rel-20161215;
+ make prefix=/usr
+}
+
+package_lua-cqueues() {
+ pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.3'
+
+ cd cqueues-rel-20161215;
+ make DESTDIR=${pkgdir} prefix=/usr install5.3
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_lua51-cqueues() {
+ pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.1'
+
+ cd cqueues-rel-20161215;
+ make DESTDIR=${pkgdir} prefix=/usr install5.1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_lua52-cqueues() {
+ pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.2'
+
+ cd cqueues-rel-20161215;
+ make DESTDIR=${pkgdir} prefix=/usr install5.2
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}