summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoractionless2020-08-10 03:03:13 +0200
committeractionless2020-08-10 03:03:13 +0200
commit5b68c33d7576befe859621b7a191314cc9b82b51 (patch)
tree29cd6db398d8653151b7f8336b51d6dc212d0cc6 /PKGBUILD
parent95e79726376c2a88976a37387fa1ce77f3f69d70 (diff)
downloadaur-5b68c33d7576befe859621b7a191314cc9b82b51.tar.gz
switch to lua5.4 ; use variable for lua version to ease the maintenance
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6af199eebc90..2fe94cf8bc5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgbase=lgi
pkgbase=lua-lgi-git
pkgname=$pkgbase
-pkgver=0.9.1.r26.g93eab44
-pkgrel=2
+pkgver=0.9.2.r55.g05038e4
+pkgrel=1
pkgdesc='Lua bindings for gnome/gobject using gobject-introspection library'
arch=(i686 x86_64)
url='https://github.com/pavouk/lgi'
@@ -19,6 +19,7 @@ conflicts=('lgi' 'lua-lgi')
provides=('lua-lgi')
source=('git+https://github.com/pavouk/lgi.git')
md5sums=('SKIP')
+_LUA_VER=5.4
pkgver() {
cd $_pkgbase
@@ -28,14 +29,15 @@ pkgver() {
build() {
cd $_pkgbase
- make
+ make LUA_INCDIR=/usr/include/lua${_LUA_VER}/ \
+ LUA_CFLAGS="$(pkg-config --cflags lua${_LUA_VER}) -O2"
}
package() {
cd $_pkgbase
make \
- LUA_LIBDIR=/usr/lib/lua/5.3 \
- LUA_SHAREDIR=/usr/share/lua/5.3 \
+ LUA_LIBDIR=/usr/lib/lua/${_LUA_VER} \
+ LUA_SHAREDIR=/usr/share/lua/${_LUA_VER} \
DESTDIR="$pkgdir/" install
# dump typelib tool