summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authork15uk2019-12-04 19:26:29 +0900
committerk15uk2019-12-04 19:29:43 +0900
commit425bc5eef516bf296daeae99e8e3549bd2907f10 (patch)
tree11855007afd120001f87c119b2f1d1e822bf93b6 /PKGBUILD
downloadaur-425bc5eef516bf296daeae99e8e3549bd2907f10.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d3a40547412
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname='lua-lpeglabel-git'
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='An extension of LPeg that supports labeled failures'
+arch=('x86_64' 'armv7h')
+url='https://github.com/sqmedeiros/lpeglabel'
+license=('MIT')
+source=("$pkgname::git+https://github.com/sqmedeiros/lpeglabel")
+sha1sums=('SKIP')
+depends=('glibc')
+
+build() {
+ cd $srcdir/$pkgname
+ make -j1
+}
+package() {
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ install -Dm644 $srcdir/$pkgname/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ mkdir -p $pkgdir/usr/lib/lua/5.3/
+ mkdir -p $pkgdir/usr/share/lua/5.3/
+ install -m 755 $srcdir/$pkgname/lpeglabel.so $pkgdir/usr/lib/lua/5.3
+ install -m 755 $srcdir/$pkgname/relabel.lua $pkgdir/usr/share/lua/5.3
+}