summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2024-03-19 14:37:25 +0300
committerCaleb Maclennan2024-03-19 14:37:25 +0300
commit7af51cd7187e83bced172797fe1d601382e19153 (patch)
treeb1ac088aedca2a80be31ec631abb40a1453978f5 /PKGBUILD
parentd9ee611e8a49bf460cfed2ccd83c4c4cbe163f5f (diff)
downloadaur-7af51cd7187e83bced172797fe1d601382e19153.tar.gz
upgpkg: lua-luacov 0.15.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 28 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87bdc94489ff..a6240ff0c0f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,48 @@
_rockname=luacov
pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
-pkgver=0.14.0
+pkgver=0.15.0
_rockrel=1
-pkgrel=6
+pkgrel=1
pkgdesc='Coverage analysis tool for Lua scripts'
-arch=('i686' 'x86_64')
+arch=(x86_64 i686)
url="https://keplerproject.github.io/$_rockname"
-license=('MIT')
-makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
-source=("$_rockname-$pkgver.tar.gz::https://github.com/keplerproject/$_rockname/archive/v$pkgver.tar.gz")
-sha256sums=('b48eb004f0a74bc64aa1419d9999057b9595668c37abfa4a126de4083d89ef44')
+license=(MIT)
+makedepends=(lua
+ lua53
+ lua52
+ lua51
+ luarocks)
+_archive="$_rockname-$pkgver"
+source=("https://github.com/keplerproject/$_rockname/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('19ebe0fdd5dd05ab63d5192371dcf272f2c7ccea5366e98fee440a2f30e021d8')
-_package_helper() {
- cd "$_rockname-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
- make --deps-mode=none --no-manifest "$_rockname-scm-$_rockrel.rockspec"
- find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
+_package() {
+ cd "$_archive"
+ luarocks --lua-version "$1" --tree "$pkgdir/usr/" \
+ make --deps-mode none --no-manifest "$_rockname-scm-$_rockrel.rockspec"
+ find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
}
package_lua-luacov() {
- depends+=('lua')
- _package_helper 5.4
+ depends+=(lua)
+ _package 5.4
}
package_lua53-luacov() {
- depends+=('lua53')
- _package_helper 5.3
- rm "$pkgdir"/usr/bin/luacov
+ depends+=(lua53)
+ _package 5.3
+ rm "$pkgdir/usr/bin/luacov"
}
package_lua52-luacov() {
- depends+=('lua52')
- _package_helper 5.2
- rm "$pkgdir"/usr/bin/luacov
+ depends+=(lua52)
+ _package 5.2
+ rm "$pkgdir/usr/bin/luacov"
}
package_lua51-luacov() {
- depends+=('lua51')
- _package_helper 5.1
- rm "$pkgdir"/usr/bin/luacov
+ depends+=(lua51)
+ _package 5.1
+ rm "$pkgdir/usr/bin/luacov"
}