summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2023-07-08 14:53:03 +0200
committerKokaKiwi2023-07-08 14:53:03 +0200
commit882fe1ae0e17132c62129ab1dcee107e7bfbe5b6 (patch)
treed5beb28f57bd43ccf4bb605b4ecfec95e89c8cba /PKGBUILD
parent033ce5abb5b6f8bd2f3b24676704097c91298e53 (diff)
downloadaur-882fe1ae0e17132c62129ab1dcee107e7bfbe5b6.tar.gz
upgpkg: lua-moonscript 0.5.0-1
- Add license file - Add lua51-moonscript package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23fc17cc73a8..04678813b470 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _rockrel=1
pkgbase="lua-$_rockname"
pkgname=(
"lua-$_rockname"
- # "lua51-$_rockname"
+ "lua51-$_rockname"
"lua52-$_rockname"
"lua53-$_rockname"
)
@@ -17,10 +17,15 @@ pkgdesc='Dynamic scripting language that compiles into Lua'
url='https://moonscript.org'
license=('MIT')
arch=(any)
-makedepends=(luarocks lua lua51 lua52 lua53)
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/leafo/moonscript/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('1adb5bb38f9c6f306250f6e90d92796fe100408ee062ac0d14f3c4c22c92e682')
-b2sums=('bda1e8fcd0191e8525ed6a7ecaf393712e24f8242b1dba5019b03f539d1e9acaa74faf67a1e3acddbb9b05f5cb570496d9910ff4f3a86986f2a8aa92234b41ef')
+makedepends=(
+ 'luarocks' 'lua'{,51,52,53}
+)
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/leafo/moonscript/archive/refs/tags/v$pkgver.tar.gz"
+ LICENSE)
+sha256sums=('1adb5bb38f9c6f306250f6e90d92796fe100408ee062ac0d14f3c4c22c92e682'
+ '81dfcb5d1f1b97c76b5dec57809e203c536aac48e66260d4563137283717280b')
+b2sums=('bda1e8fcd0191e8525ed6a7ecaf393712e24f8242b1dba5019b03f539d1e9acaa74faf67a1e3acddbb9b05f5cb570496d9910ff4f3a86986f2a8aa92234b41ef'
+ 'bd1d80f17545a9e82d40589969b3eafea115715890fc3fcbe8f83fdff2839ecb1a8dd913beb97b56a8b4758d3d633f785b485063093f39a7876cc1e47623ed3f')
_package() {
depends+=("${pkgname%-*}")
@@ -35,7 +40,11 @@ _package() {
luarocks --lua-version="$lua_version" --tree="$pkgdir/usr" \
make --deps-mode=none --no-manifest "$_rockname-dev-$_rockrel.rockspec"
- rm -rf "$pkgdir/usr/bin" "$pkgdir/usr/lib/luarocks/rocks-$lua_version/$_rockname/$_rockver-$_rockrel/bin"
+ rm -rf \
+ "$pkgdir/usr/bin" \
+ "$pkgdir/usr/lib/luarocks/rocks-$lua_version/$_rockname/"*"/bin"
+
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/LICENSE"
}
package_lua-moonscript() {