summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Krause2016-11-08 15:03:10 +0100
committerChristian Krause2016-11-08 15:03:10 +0100
commit1b5e78b6c0a191eb3e6ff1a62934da0df762695d (patch)
tree59e6883bd60c820e47d82e906e09b489d6724cd7 /PKGBUILD
parent8a0e3e5153de03c220d43085a4ff65492c6fc9bc (diff)
downloadaur-1b5e78b6c0a191eb3e6ff1a62934da0df762695d.tar.gz
lua-posix-33.4.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 17 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27d305e64379..e19d4485faee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,29 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: Alexander Rødseth <rodseth@gmail.com>
-# Contributor: Sébastien Luttringer
-# Contributor: SpepS <dreamspepser at yahoo dot it>
-# Contributor: Laszlo Papp <djszapi at archlinux us>
-# Contributor: Donald Ephraim Curtis <dcurtis@gmail.com>
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=lua-posix
-pkgver=33.2.1.21.g33a18d1
+pkgver=33.4.0
pkgrel=1
-pkgdesc='POSIX library for Lua'
-arch=('x86_64' 'i686')
-url='https://github.com/luaposix/luaposix'
-license=('MIT')
+pkgdesc="posix bindings for Lua"
+arch=('i686' 'x86_64')
+url="https://github.com/luaposix/luaposix#luaposix"
+license=('custom')
depends=('lua')
-makedepends=('git' 'help2man' 'ldoc')
-options=('!makeflags')
-source=("$pkgname::git://github.com/luaposix/luaposix.git")
-md5sums=('SKIP')
+conflicts=('lua-posix-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/luaposix/luaposix/archive/release-v$pkgver.tar.gz")
+md5sums=('b36ff049095f28752caeb0b46144516c')
-pkgver() {
- cd "$pkgname"
- git describe --tags |sed 's+-+.+g' | cut -c2-
-}
+build() {
+ cd $srcdir/luaposix-release-v$pkgver
-prepare() {
- cd "$pkgname"
- sed -i '19,20d' bootstrap.conf
-}
+ ./configure --prefix=/usr
-build() {
- cd "$pkgname"
- ./bootstrap
- ./configure \
- LUA=/usr/bin/lua \
- --prefix=/usr \
- --libdir=/usr/lib/lua/5.2 \
- --datadir=/usr/share/lua/5.2 \
- --docdir=/usr/share/doc/lua-posix
make
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ cd $srcdir/luaposix-release-v$pkgver
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
}