summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Berquist2015-09-17 20:35:32 -0400
committerEric Berquist2015-09-17 20:35:32 -0400
commita69c4edb512c25fd5ea7c9d7781d9ea0e85e26aa (patch)
treebd1cced446035e4f855c321a44f1d0b0b4068e8c /PKGBUILD
parentccd3fa218e10d313040842216c04119cd3e53e2a (diff)
downloadaur-a69c4edb512c25fd5ea7c9d7781d9ea0e85e26aa.tar.gz
Make the package independent of the Lua version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abfb58549545..88c873c3ef66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,44 +3,52 @@
# Contributor: SpepS <dreamspepser at yahoo dot it>
# Contributor: Laszlo Papp <djszapi at archlinux us>
# Contributor: Donald Ephraim Curtis <dcurtis@gmail.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
-pkgname=lua-posix-git
-pkgver=33.0.0.18.ge7dee4d
+_pkgname=lua-posix
+pkgname="${_pkgname}-git"
+pkgver=33.2.1.73.g5536f10
pkgrel=1
pkgdesc='POSIX library for Lua'
arch=('x86_64' 'i686')
url='https://github.com/luaposix/luaposix'
license=('MIT')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
depends=('lua')
-conflicts=('lua-posix')
-provides=('lua-posix')
makedepends=('git' 'help2man' 'ldoc')
options=('!makeflags')
-source=("git://github.com/luaposix/luaposix.git")
+source=("${_pkgname}::git://github.com/luaposix/luaposix.git")
md5sums=('SKIP')
-_gitname=luaposix
pkgver() {
- cd "$_gitname"
+ cd "${_pkgname}"
git describe --always | sed 's+^v++' | sed 's+-+.+g'
}
+prepare() {
+ cd "${_pkgname}"
+ sed -i '19,20d' bootstrap.conf
+}
+
build() {
- cd "$_gitname"
+ cd "${_pkgname}"
+
+ luaver=$(/usr/bin/lua -v | cut -d " " -f 2 | cut -d "." -f 1,2)
./bootstrap
./configure \
LUA=/usr/bin/lua \
--prefix=/usr \
- --libdir=/usr/lib/lua/5.2 \
- --datadir=/usr/share/lua/5.2 \
+ --libdir=/usr/lib/lua/${luaver} \
+ --datadir=/usr/share/lua/${luaver} \
--docdir=/usr/share/doc/lua-posix
make
}
package() {
- cd "$_gitname"
+ cd "${_pkgname}"
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}