summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHelloImWar2023-01-24 23:23:59 -0500
committerHelloImWar2023-01-24 23:23:59 -0500
commit6847c5c980a4fb59f9b6fec428948ae439adffba (patch)
tree14402b7148af4b1c701e54509095f4a29d66f303 /PKGBUILD
downloadaur-6847c5c980a4fb59f9b6fec428948ae439adffba.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 77 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c85e9f929f1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: HelloImWar <helloimwar at proton dot me>
+
+pkgname=(lua-promise-async-git lua51-promise-async-git lua52-promise-async-git lua53-promise-async-git neovim-promise-async-git)
+pkgver=1.0.0.r1.g842dca3
+pkgrel=1
+pkgdesc="Promise & Async in Lua"
+arch=('any')
+url="https://github.com/kevinhwang91/promise-async"
+license=('BSD')
+makedepends=('git')
+source=("lua-promise-async-git::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd lua-promise-async-git
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package_lua-promise-async-git() {
+ provides=(lua-promise-async)
+ conflicts=(lua-promise-async)
+ cd lua-promise-async-git/lua
+ find . \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/lua/5.4/{}" \;
+ cd ..
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_lua51-promise-async-git() {
+ provides=(lua51-promise-async)
+ conflicts=(lua51-promise-async)
+ cd lua-promise-async-git/lua
+ find . \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/lua/5.1/{}" \;
+ cd ..
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_lua52-promise-async-git() {
+ provides=(lua52-promise-async)
+ conflicts=(lua52-promise-async)
+ cd lua-promise-async-git/lua
+ find . \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/lua/5.2/{}" \;
+ cd ..
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_lua53-promise-async-git() {
+ provides=(lua53-promise-async)
+ conflicts=(lua53-promise-async)
+ cd lua-promise-async-git/lua
+ find . \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/lua/5.3/{}" \;
+ cd ..
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_neovim-promise-async-git() {
+ provides=(neovim-promise-async)
+ conflicts=(neovim-promise-async)
+ cd lua-promise-async-git/lua
+ find . \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/plugins/start/neovim-promise-async-git/lua/{}" \;
+ cd ..
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}