summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Smith2019-01-26 14:34:46 -0500
committerStephen Smith2019-01-26 14:34:46 -0500
commita2584135de5232fe66aad6d17f153725d1788532 (patch)
treefe44e9b7082fd461cad255ece5a5d04e1fd9495c /PKGBUILD
downloadaur-a2584135de5232fe66aad6d17f153725d1788532.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f784c83228b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+
+pkgname=lua-wsapi
+_rockname=wsapi
+pkgver=1.7
+pkgrel=1
+pkgdesc="WSAPI is an API that abstracts the web server from Lua web applications."
+arch=('i686' 'x86_64')
+url="http://keplerproject.github.com/wsapi"
+license=('MIT')
+depends=('lua' 'lua-luafilesystem' 'lua-rings' 'lua-coxpcall')
+makedepends=('luarocks')
+conflicts=()
+source=("${_rockname}-${pkgver}.tar.gz::https://github.com/keplerproject/${_rockname}/archive/v${pkgver}.tar.gz")
+md5sums=('aacadf9dabeb82b044cb3f1006c5df0d')
+
+build() {
+ cd "$_rockname-$pkgver"
+ luarocks make --pack-binary-rock --deps-mode=none "rockspec/$_rockname-$pkgver-1.rockspec"
+}
+
+package() {
+ luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$_rockname-$pkgver"/*.rock
+ find "$pkgdir/usr" -name manifest -delete
+}