summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-06 11:13:09 +0300
committerCaleb Maclennan2020-08-06 11:13:09 +0300
commit0ac33432ebf6e947dcd274f0d3df44ba887cb168 (patch)
treeab0ed62d385b919eed03fb30f1165e01ad90077d /PKGBUILD
parent0b14c06ca9f935eef295d0c68e822a0e6f6f937d (diff)
downloadaur-lua-yaml.tar.gz
upgpkg: lua-yaml 1.1.2-4
Bump default to Lua 5.4 and add Lua 5.3 split package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78bb58fd6800..e13290ce2224 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
_rockname=yaml
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=1.1.2
_rockrel=1
-pkgrel=3
+pkgrel=4
pkgdesc='LibYAML binding for Lua'
arch=('i686' 'x86_64')
url="https://lubyk.github.io/lubyk/$_rockname.html"
license=('MIT')
_lua_deps=('lub')
-makedepends=('luarocks' 'lua52' 'lua51')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::https://github.com/lubyk/$_rockname/archive/REL-$pkgver.tar.gz")
sha256sums=('b4391d182677ab644403bf1ac028c7421c2605db124f9792193013c582a273ec')
_package_helper() {
cd "$_rockname-REL-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
}
package_lua-yaml() {
depends+=('lua' "${_lua_deps[@]/#/lua-}")
+ _package_helper 5.4
+}
+
+package_lua53-yaml() {
+ depends+=('lua53' "${_lua_deps[@]/#/lua53-}")
_package_helper 5.3
}