summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordaurnimator2018-04-13 02:12:14 +1000
committerdaurnimator2018-04-13 02:12:14 +1000
commit8baf6a639f4453d8fbd92746e433182b52bfec34 (patch)
tree7e971e3b1f53065df9bfe162649de903a03ffb21 /PKGBUILD
downloadaur-8baf6a639f4453d8fbd92746e433182b52bfec34.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16a973682c5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: daurnimator <quae@daurnimator.com>
+
+pkgname=lua-yue-bin
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Lua bindings to Yue: A library for creating native cross-platform GUI apps."
+arch=('i686' 'x86_64')
+url="http://libyue.com/"
+license=('LGPL')
+
+source=(
+ "https://github.com/yue/yue/releases/download/v${pkgver}/lua_yue_lua_5.3_v${pkgver}_linux_x64.zip"
+)
+
+md5sums=('b8911506da6041d0e2f6ad80e05e4324')
+
+package() {
+ install -D yue.so "$pkgdir"/usr/lib/lua/5.3/yue.so
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}