summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Aladin2016-08-22 16:41:10 +0300
committerGeorge Aladin2016-08-22 16:41:10 +0300
commit8c74aa824de4e2087dd0b41726f4b09df34ba375 (patch)
tree6d44dcee6aae281d78499d9ac787434e32d1bf5f /PKGBUILD
downloadaur-8c74aa824de4e2087dd0b41726f4b09df34ba375.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bc8105130d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sinnamon (George Aladin) <AngleSi at yahoo dot com>
+
+pkgname=lua51-ex
+_pkgname=lua-ex
+pkgver=2.07.2009
+pkgrel=1
+pkgdesc="ExtensionProposal is an API and implementation for additional non-ANSI functions in the os and io namespaces."
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://lua-users.org/wiki/ExtensionProposal"
+depends=('lua51')
+
+source=('https://github.com/luaforge/lua-ex/archive/master.zip')
+
+md5sums=('730831f88d3dea4fcddadd81f2c6cb90')
+
+prepare() {
+ cd ${_pkgname}-master
+ ##
+ echo "LUAINC= -I/usr/include/lua5.1/" > conf
+ echo "LUALIB= -L/usr/lib/ -llua5.1" >> conf
+ echo "POSIX_SPAWN= -DMISSING_POSIX_SPAWN" >> conf
+ echo "EXTRA= posix_spawn.o" >> conf
+ ##
+ sed -i 's/$(INCLUDES)/$(INCLUDES) -fPIC/g' posix/Makefile
+}
+
+build() {
+ cd ${_pkgname}-master
+ make linux || return 1
+}
+
+package() {
+ cd ${_pkgname}-master/posix/
+ install -D ex.so ${pkgdir}/usr/lib/lua/5.1/ex.so
+}