summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcelogeek2021-05-11 15:30:58 +0200
committercelogeek2021-05-11 15:31:21 +0200
commit046569415c5b660a003c33bab415bff7bdabb1ad (patch)
treee7ef624ea5606cb950de15c7cb193e6a9a07bb35 /PKGBUILD
downloadaur-046569415c5b660a003c33bab415bff7bdabb1ad.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c0b2d425e49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Celogeek <arch-aur-f5d67e@celogeek.com>
+
+pkgname=lua52-base64
+pkgver=1.5.3
+pkgrel=1
+pkgdesc='LUA JWT Jitsi'
+arch=('any')
+url='https://github.com/iskolbin/lbase64'
+license=('MIT')
+makedepends=('luarocks' 'lua52')
+source=("git+https://github.com/iskolbin/lbase64#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "lbase64"
+ luarocks make --pack-binary-rock --lua-version="5.2" --deps-mode=none rockspec/base64-1.5-3.rockspec
+}
+
+package() {
+ cd "lbase64"
+ luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none --no-manifest *.rock
+}
+
+