summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorosch2018-03-28 23:25:12 +0200
committerosch2018-03-28 23:25:12 +0200
commit82b8ee24a7a1eeebdd8a426c801087bcaf37a0b5 (patch)
treef7d1b7a2a70b92b3158f1e1fde0ce68bafc832e5 /PKGBUILD
downloadaur-82b8ee24a7a1eeebdd8a426c801087bcaf37a0b5.tar.gz
initial release 0.01
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b28ec51d5a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: osch <oliver@luced.de>
+pkgname=luced
+pkgver=0.01
+pkgrel=1
+epoch=
+pkgdesc="The Lucid Editor - a fast & lightweight text editor for X11."
+arch=('x86_64')
+url="https://luced.de"
+license=('GPL2')
+groups=()
+depends=('libx11'
+ 'libxpm'
+ 'xorg-fonts-75dpi')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://luced.de/releases/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install-strip
+}
+md5sums=('3b0a8b1480494d83f0d69e4853495712')