summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeanbon2018-09-23 10:51:51 +0200
committerJeanbon2018-09-23 10:51:51 +0200
commit0787dbe047dab85eed757dc97757ee07fda29b5c (patch)
tree1947c6e047570873e8dcdc5c4285ce0aeb7b991a /PKGBUILD
parent7b5279bab1d09d208a564f0fc79598b835fe0f2b (diff)
downloadaur-0787dbe047dab85eed757dc97757ee07fda29b5c.tar.gz
Monotonic pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27620ceb7a6c..34eb1b50922b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ _pkgname=lugaru
_gitname=lugaru
pkgname=$_pkgname-git
-pkgver=1a6ef83
+pkgver=r968.efdb8d8
pkgrel=1
pkgdesc="A third-person action game featuring a unique close-range combat system"
url="https://osslugaru.gitlab.io"
@@ -10,7 +10,6 @@ license=('GPL')
arch=('i686' 'x86_64')
depends=('sdl2' 'glu' 'libjpeg-turbo' 'libpng' 'openal' 'libvorbis' 'zlib')
makedepends=('cmake')
-options=('!optipng')
conflicts=('lugaru-hg' 'lugaruhd-hg' 'lugaru')
source=("git+https://gitlab.com/osslugaru/lugaru.git"
"${_pkgname}.desktop")
@@ -18,8 +17,8 @@ sha256sums=('SKIP'
'c97bbd82701c07692f35fd86d0a4b4fdb2d5380a5672dde75617ae15389bfd15')
pkgver() {
- cd "$srcdir/$_gitname"
- git describe --always --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {